Search references for PROTOCOL ENGINEERING. Phrases containing PROTOCOL ENGINEERING
See searches and references containing PROTOCOL ENGINEERING!PROTOCOL ENGINEERING
Field that applies systematic methods for developing communication protocols
Protocol engineering is the application of systematic methods to the development of communication protocols. It uses many of the principles of software
Protocol_engineering
Decentralized social networking protocol
The AT Protocol (Authenticated Transfer Protocol, pronounced "at protocol", commonly shortened to ATproto or "ATP") is a protocol and set of open standards
AT_Protocol
Framework for communication protocols used in IP networking
foundational protocols in the suite are the Transmission Control Protocol (TCP), the User Datagram Protocol (UDP), and the Internet Protocol (IP). Early
Internet_protocol_suite
Network protocol that provides file management over any reliable data stream
stream. It was designed by the Internet Engineering Task Force (IETF) as an extension of the Secure Shell protocol (SSH) version 2.0 to provide secure file
SSH_File_Transfer_Protocol
Computer network management and monitoring protocol
and security. SNMP is a component of the Internet Protocol Suite as defined by the Internet Engineering Task Force (IETF). It consists of a set of standards
Simple Network Management Protocol
Simple_Network_Management_Protocol
Communications protocol not documented by a publicly available standard
In telecommunications, a proprietary protocol is a communications protocol owned by a single organization or individual. Ownership by a single organization
Proprietary_protocol
Protocol for delivering audio and video over IP networks
Internet Engineering Task Force (IETF) published RFC 741 in 1977 and began developing RTP in 1992, and would go on to develop Session Announcement Protocol (SAP)
Real-time_Transport_Protocol
Application layer protocol
HTTP (Hypertext Transfer Protocol) is an application layer protocol in the Internet protocol suite for distributed, collaborative, hypermedia information
HTTP
Networking protocol for clock synchronization
The Network Time Protocol (NTP) is a networking protocol for clock synchronization between computer systems over packet-switched, variable-latency data
Network_Time_Protocol
Data link layer communication protocol
In computer networking, Point-to-Point Protocol (PPP) is a data link layer (layer 2) communication protocol between two routers directly without any host
Point-to-Point_Protocol
April Fool's joke about facetious communications protocol
Control Protocol (HTCPCP) is a facetious communication protocol for controlling, monitoring, and diagnosing coffee pots. As part of Internet Engineering Task
Hyper Text Coffee Pot Control Protocol
Hyper_Text_Coffee_Pot_Control_Protocol
System for exchanging messages between computing systems
communication protocol is a system of rules that allows two or more entities of a communications system to transmit information. The protocol defines the
Communication_protocol
Version 6 of the Internet Protocol
Internet Protocol version 6 (IPv6) is the most recent version of the Internet Protocol (IP), the communications protocol that provides an identification
IPv6
Communication protocol that allows connections between networks
The Internet Protocol (IP) is the network layer communications protocol in the Internet protocol suite for relaying datagrams across network boundaries
Internet_Protocol
Voice-over-IP communications protocol
The Session Initiation Protocol (SIP) is a signaling protocol used for initiating, maintaining, modifying, and terminating communication sessions that
Session_Initiation_Protocol
Principal protocol used to assign IPv4 addresses on an IPv4 network
The Dynamic Host Configuration Protocol (DHCP) is a network management protocol used on Internet Protocol (IP) networks for automatically assigning IP
Dynamic Host Configuration Protocol
Dynamic_Host_Configuration_Protocol
Simple network protocols for the exchange of human-oriented status and user information
computer networking, the Name/Finger protocol and the Finger user information protocol are simple network protocols for the exchange of human-oriented status
Finger_(protocol)
Protocol for communicating routing information on the Internet
Border Gateway Protocol (BGP) is a standardized exterior gateway protocol designed to exchange routing and reachability information among autonomous systems
Border_Gateway_Protocol
Computer network protocol
Control Transmission Protocol (SCTP) is a computer networking communications protocol in the transport layer of the Internet protocol suite. Originally intended
Stream Control Transmission Protocol
Stream_Control_Transmission_Protocol
Protocol for communicating between LLMs and applications
The Model Context Protocol (MCP) is an open standard and open-source framework introduced by Anthropic in November 2024 to standardize the way artificial
Model_Context_Protocol
Technology discipline within engineering
Dave; West, Colin H. (December 2010). "Some notes on the history of protocol engineering". Computer Networks. 54 (18): 3197–3209. doi:10.1016/j.comnet.2010
Computer_network_engineering
German-Canadian computer scientist
the University of Ottawa. He is known for his work in the area of protocol engineering and distributed applications. Gregor von Bochmann grew up in an artistic
Gregor von Bochmann (computer scientist)
Gregor_von_Bochmann_(computer_scientist)
Open internet standards organization
Internet Engineering Task Force (IETF) is a standards organization for the Internet responsible for the technical standards of the Internet protocol suite
Internet Engineering Task Force
Internet_Engineering_Task_Force
Associates addresses in the layers of a networked device implementation
The Address Resolution Protocol (ARP) is a communication protocol for discovering the link layer address, such as a MAC address, associated with an internet
Address_Resolution_Protocol
Fourth version of the Internet Protocol
Internet Protocol version 4 (IPv4) is the first version of the Internet Protocol (IP) as a standalone specification. It is one of the core protocols of standards-based
IPv4
Internet protocol used for error messages in network operations
The Internet Control Message Protocol (ICMP) is a supporting protocol in the Internet protocol suite. It is used by network devices, including routers
Internet Control Message Protocol
Internet_Control_Message_Protocol
Very basic transfer protocol over UDP
The Trivial File Transfer Protocol (TFTP) is a simple communication protocol for transmitting or receiving files in a client-server application. A primary
Trivial File Transfer Protocol
Trivial_File_Transfer_Protocol
Distributed file system protocol
security, and introduces a stateful protocol. Version 4 became the first version developed with the Internet Engineering Task Force (IETF) after Sun Microsystems
Network_File_System
Cryptographic protocols for securing data in transit
is a cryptographic protocol designed to provide secured communications over a computer network, such as the Internet. The protocol is widely used in applications
Transport_Layer_Security
Numerical label used to identify a network interface in an IP network
An Internet Protocol address (IP address) is a numerical label, such as 192.168.1.1 or 2001:0db8:0000:0000:0000:8a2e:0370:7334, that is assigned to a device
IP_address
Protocol in the Internet protocol suite used with IPv6
Neighbor Discovery Protocol (NDP), or simply Neighbor Discovery (ND), is a protocol of the Internet protocol suite used with Internet Protocol Version 6 (IPv6)
Neighbor_Discovery_Protocol
Cryptographic network protocol
The Secure Shell Protocol (SSH Protocol) is a cryptographic network protocol for operating network services securely over an unsecured network. Its most
Secure_Shell
Hierarchical interface
complex message encoding and passing methods and other aspects of protocol engineering. For most operations, common file utilities can be used, so even
Synthetic_file_system
HTTP extension supporting TLS encryption
Hypertext Transfer Protocol Secure (HTTPS) is an extension of the Hypertext Transfer Protocol (HTTP). It uses encryption for secure communication over
HTTPS
Utility software developed by Samsung
Samsung devices in Odin mode (also called download mode) through the thor protocol. It can be used to flash a custom recovery firmware image (as opposed to
Odin (firmware flashing software)
Odin_(firmware_flashing_software)
Network event logging system and protocol
customers to problems. The Syslog protocol is defined by Request for Comments (RFC) documents published by the Internet Engineering Task Force (Internet standards)
Syslog
Address on the World Wide Web
example of a web page URL, https://www.example.com/index.html indicates protocol https, hostname www.example.com, and file name index.html. The Uniform
URL
Email handling protocol
and Neil Jenkins wrote on the Internet Engineering Task Force (IETF) news site that "the current open protocols connecting email clients and servers, such
JSON Meta Application Protocol
JSON_Meta_Application_Protocol
Network routing scheme based on labels identifying paths
IP protocol data units and Virtual Private LAN Service (VPLS) Ethernet traffic. Major applications of MPLS are telecommunications traffic engineering and
Multiprotocol_Label_Switching
Extension of a private network across a public one
the Internet, via the use of encryption and tunneling protocols. In a VPN, a tunneling protocol is used to transfer network messages from one network
Virtual_private_network
network protocol engineering. It is a term that is used for information that times out (goes away) unless refreshed, which allows protocols to recover
Soft_state
Network protocol supporting distributed directory information services
Lightweight Directory Access Protocol (LDAP /ˈɛl.dæp/) is an Internet protocol for accessing directory information services that act in accordance with
Lightweight Directory Access Protocol
Lightweight_Directory_Access_Protocol
Computer communications protocol
In computer networks, a tunneling protocol is a communication protocol that allows for the movement of data from one network to another. They can, for
Tunneling_protocol
Principal protocol used for transmission of datagrams across an IP network
computer networking, the User Datagram Protocol (UDP) is one of the core communication protocols of the Internet protocol suite used to send messages (transported
User_Datagram_Protocol
Secure network protocol suite
In computing, Internet Protocol Security (IPsec) is a secure network protocol suite that authenticates and encrypts packets of data to provide secure encrypted
IPsec
Process of extracting design information from anything artificial
the problem of protocol reverse-engineering can be partitioned into two subproblems: message format and state-machine reverse-engineering. The message formats
Reverse_engineering
Internet protocol
Host Identity Protocol (HIP) Architecture. Internet Engineering Task Force. sec. 4.1. doi:10.17487/RFC4423. RFC 4423. "Host Identity Protocol (hip)". IETF
Host_Identity_Protocol
Protocol to run DNS queries over HTTPS
DNS over HTTPS (DoH) is a protocol for performing remote Domain Name System (DNS) resolution via the HTTPS protocol. A goal of the method is to increase
DNS_over_HTTPS
Transport layer computer network protocol
QUIC (/kwɪk/) is a general-purpose transport layer network protocol initially designed by Jim Roskind at Google. It was first implemented and deployed
QUIC
Internet protocol used for error messages in network operations
Control Message Protocol version 6 (ICMPv6) is the implementation of the Internet Control Message Protocol (ICMP) for Internet Protocol version 6 (IPv6)
ICMPv6
Suite of IETF specifications
Internet Engineering Task Force (IETF) for securing data exchanged in the Domain Name System (DNS) in Internet Protocol (IP) networks. The protocol provides
Domain Name System Security Extensions
Domain_Name_System_Security_Extensions
Information exchange standards
open-standard protocol suite instead has been met by the Internet protocol suite, maintained by the Internet Engineering Task Force (IETF). The OSI protocol stack
OSI_protocols
Internet protocol
and IKEv2) is the protocol used to set up a security association (SA) in the IPsec protocol suite. IKE builds upon the Oakley protocol and ISAKMP. IKE uses
Internet_Key_Exchange
Method of user authentication in computing
November 2008, at the 73rd Internet Engineering Task Force (IETF) meeting, in Minneapolis, an oAuth BoF for include the protocol into the IETF for standardization
OAuth
Communications protocol
(April 2022). The Datagram Transport Layer Security (DTLS) Protocol Version 1.3. Internet Engineering Task Force TLS workgroup. doi:10.17487/RFC9147. RFC 9147
Datagram Transport Layer Security
Datagram_Transport_Layer_Security
Label to identify a network interface of a computer or other network node
An Internet Protocol version 6 address (IPv6 address) is a numeric label that is used to identify and locate a network interface of a computer or a network
IPv6_address
Topics referred to by the same term
Equality-generating dependency Esophagogastroduodenoscopy Ethernet Global Data Protocol Engineering Graphics and Design, an educational subject that focuses on the development
EGD
Proposal to carry IP traffic by birds
Protocol (IP) traffic by birds such as homing pigeons. IP over Avian Carriers was initially described in RFC 1149 issued by the Internet Engineering Task
IP_over_Avian_Carriers
Israeli computer scientist
Yannakakis, Mihalis (1999). "Black Box Checking". Formal Methods for Protocol Engineering and Distributed Systems. IFIP Advances in Information and Communication
Doron_A._Peled
is a list of reserved Internet Protocol (IP) addresses. In the Internet addressing architecture, the Internet Engineering Task Force (IETF) and the Internet
List_of_reserved_IP_addresses
Private university in Karnataka, India
Mechanical Engineering Book titled "Communication Protocol Engineering" by Pallapa Venkataram, Sunilkumar S Manvi (Dean-Faculty of Engineering), B Satish
REVA_University
Network protocol
Device Protocol implemented in many NAT routers. The protocol was published as an informational Request for Comments (RFC) by the Internet Engineering Task
NAT_Port_Mapping_Protocol
Computer instant messaging protocol
presence protocol suite based on Session Initiation Protocol (SIP) managed by the Internet Engineering Task Force. SIMPLE applies SIP to the problems of:
SIMPLE (instant messaging protocol)
SIMPLE_(instant_messaging_protocol)
numbers used by protocols for operation of network applications. The Transmission Control Protocol (TCP) and the User Datagram Protocol (UDP) only need
List of TCP and UDP port numbers
List_of_TCP_and_UDP_port_numbers
Network protocol used by the Web
revision of the HTTP network protocol used by the World Wide Web. It was derived from the earlier experimental SPDY protocol, originally developed by Google
HTTP/2
Specialized Internet application protocol
Constrained Application Protocol (CoAP) is a specialized UDP-based Internet application protocol for constrained devices, as defined in RFC 7252 (published
Constrained Application Protocol
Constrained_Application_Protocol
Computer network protocol
Registration Data Access Protocol (RDAP) is a computer network communications protocol standardized by a working group at the Internet Engineering Task Force in
Registration Data Access Protocol
Registration_Data_Access_Protocol
Protocol to manage public key certificates
The Automatic Certificate Management Environment (ACME) protocol is a communication protocol for automating interactions between certificate authorities
Automatic Certificate Management Environment
Automatic_Certificate_Management_Environment
Computer network routing protocol
Intermediate System (IS-IS, also written ISIS) is a link-state interior gateway protocol (IGP), typically deployed within a single autonomous system, and is used
IS-IS
Inter-router protocol that automatically assigns routers to hosts
The Virtual Router Redundancy Protocol (VRRP) is a network redundancy protocol standardized by the Internet Engineering Task Force (IETF). It provides
Virtual Router Redundancy Protocol
Virtual_Router_Redundancy_Protocol
HTTP extension for collaborative editing
defined in RFC 4918 by a working group of the Internet Engineering Task Force (IETF). The WebDAV protocol provides a framework for users to create, change and
WebDAV
Computer network protocol
Traversal Using Relays around NAT (TURN) is a protocol that assists in traversal of network address translators (NAT) or firewalls for multimedia applications
Traversal Using Relays around NAT
Traversal_Using_Relays_around_NAT
Computer network protocol
WHOIS (pronounced as the phrase "who is") is a query and response protocol that is used for querying databases that store an Internet resource's registered
WHOIS
Type of testing for standards, contracts and regulations
biocompatibility proofing data and communications protocol engineering document engineering electronic and electrical engineering medical procedure proofing pharmaceutical
Conformance_testing
Industrial safety communications protocol
openSAFETY, bus-independent protocol." Control Engineering website. 11 August 2010. Lydon, Bill. "Multivendor Ethernet Safety Protocol - Noble Goal." Automation
OpenSafety
traffic engineering in IP and MPLS networks. Traditional MPLS Traffic Engineering relied on signaling protocols such as Resource Reservation Protocol-Traffic
Segment_routing
Authentication networking protocol
Remote Authentication Dial-In User Service (RADIUS) is a networking protocol that provides centralized authentication, authorization, and accounting (AAA)
RADIUS
became a standards-track protocol at the Internet Engineering Task Force (IETF). Session Initiation Protocol (SIP) RTP audio video profile Ejub Kajan (6 December
Internet Protocol Device Control
Internet_Protocol_Device_Control
Former Internet protocol
from EGP to BGP. E. Rosen (October 1982). EXTERIOR GATEWAY PROTOCOL (EGP). Internet Engineering Task Force. doi:10.17487/RFC0827. RFC 827. Status Unknown
Exterior_Gateway_Protocol
Object that manipulates, creates, describes, and implements other objects
reverse engineering. When compilation is not available at run-time there are additional complications for the implementation of metaobject protocol. For
Metaobject
The Open Control Architecture (OCA) is a communications protocol architecture for control, monitoring, and connection management of networked audio and
Open_Control_Architecture
Communication protocol for printers
The Internet Printing Protocol (IPP) is a specialized communication protocol used between client devices (computers, mobile phones, tablets, etc.) and
Internet_Printing_Protocol
1987 treaty to protect the ozone layer
The Montreal Protocol, officially the Montreal Protocol on Substances That Deplete the Ozone Layer, is an international treaty designed to protect the
Montreal_Protocol
Computer network protocol
ISBN 978-1-83508-317-8. "Overview BGP Monitoring Protocol" (PDF). "BGP Monitoring Protocol (BMP)". Internet Engineering Task Force. June 2016. v t e
BGP_Monitoring_Protocol
File indicating parts for web crawling
announced the proposal of the Robots Exclusion Protocol as an official standard under Internet Engineering Task Force. A proposed standard was published
Robots.txt
Disciplines into which the field of engineering is conventionally divided
Computer-aided engineering Model-driven engineering Concurrent engineering Engineering analysis Engineering design process (engineering method) Engineering mathematics
List_of_engineering_branches
Global system of connected computer networks
underpinning and standardization of the core protocols is an activity of the non-profit Internet Engineering Task Force (IETF). The word internetted was
Internet
Network protocol for mapping ports
communications protocol for automatically configuring port forwarding, and is part of an ISO/IEC Standard rather than an Internet Engineering Task Force standard
Internet Gateway Device Protocol
Internet_Gateway_Device_Protocol
Computer network protocol
communications protocol, providing a bidirectional communication channel over a single Transmission Control Protocol (TCP) connection. The protocol was standardized
WebSocket
Interoperability standard for professional audio over IP
standard was developed by the Audio Engineering Society and first published in September 2013. It is a layer 3 protocol suite based on existing standards
AES67
Solution to the reachability problem in distributed systems (computer science)
finite-state modeling of the protocol entities, and also pointed out that a similar protocol described earlier had a design flaw. This protocol belongs to the Link
Reachability_analysis
Live distribution of digital audio across an Ethernet network
Retrieved 2010-10-15. "packet - How do I work out the Ultranet protocol?". Reverse Engineering Stack Exchange. Retrieved 2019-02-06. "RAVE Systems". Archived
Audio_networking
Terminal command scheme used to transfer data
Fast Adaptive and Secure Protocol (FASP) is a proprietary data transfer protocol. FASP is a network-optimized network protocol created by Michelle C. Munson
Fast_and_Secure_Protocol
Communications protocol for message-oriented middleware
Extensible Messaging and Presence Protocol (abbreviation XMPP, originally named Jabber) is an open communication protocol designed for instant messaging
XMPP
Public blockchain platform
alternative to Ethereum and other layer-one blockchain networks. NEAR Protocol was founded in early 2017 by Illia Polosukhin and Alexander Skidanov. Initially
NEAR_(blockchain_platform)
Computer network protocol
The Real-Time Streaming Protocol (RTSP) is an application-level network protocol designed for multiplexing and packetizing multimedia transport streams
Real-Time_Streaming_Protocol
Computer network protocol
RFB (Remote Framebuffer) is an open simple protocol for remote access to graphical user interfaces. It is applicable to all windowing systems and applications
RFB_(protocol)
Multimedia streaming protocol
The Media Dispatch Protocol (MDP) was developed by the Pro-MPEG Media Dispatch Group to provide an open standard for secure, automated, and tapeless delivery
Media_Dispatch_Protocol
Specification for Domain Name System
(DNS) protocol which had size restrictions that the Internet engineering community deemed too limited for increasing functionality of the protocol. The
Extension_Mechanisms_for_DNS
composed of three main protocols: Resource Reservation Protocol with Traffic Engineering extensions (RSVP-TE) signaling protocol. Open Shortest Path First
Generalized Multi-Protocol Label Switching
Generalized_Multi-Protocol_Label_Switching
travel, tourism, insurance
PROTOCOL ENGINEERING
PROTOCOL ENGINEERING
PROTOCOL ENGINEERING
PROTOCOL ENGINEERING
PROTOCOL ENGINEERING
PROTOCOL ENGINEERING
PROTOCOL ENGINEERING
PROTOCOL ENGINEERING
PROTOCOL ENGINEERING
travel, tourism, insurance